PSYCLE's home     
     since may 2000
  news / home  files songs boards links all registered members about psycledelics Statistics    
╗ Welcome to -psycledelics-. If this is your 1st visit please read the FAQ - Frequently Asked Questions You must register before you can post here: Please click above on Registration to register yourself. You do not need to register if you only want to read Threads.
Login with Username & Password:

Remember me on this PC.
-psycledelics-DiscussionsTECH BOARD ╗ 32-bit VSTs do not work in 64-bit Psycle
« Previous Thread Next Thread » Show a Printable Version  Send this to a Friend  Add to Favorites
Thread closed
Poll: Do you have this problem? Please only vote if you are using the x64 version of Pyscle and can or cannot successfully load 32-bit and 64-bit VSTs simultaneously.
Yes
No
Result
Author
Post
DaAwesomeP
Psycler



Date Registered:
12.2014
Location:

Posts: 2


DaAwesomeP ist offline
32-bit VSTs do not work in 64-bit Psycle        Go on top to this Page

I think that JBridge might not be working correctly. I have the 64-bit version of Psycle 1.12.0 on Windows 8.1 64-bit. I can successfully select the path and load 64-bit plugins, but when I check off the "32<->64 bit bridge support" and "JBride" options, the 32-bit VSTs are listed under "Non-working or not a machine." When I go back to settings, the 32-bit path and bride options are greyed out (disabled). I used to have a 32-bit machine, so I didn't have to worry about this. My new 64-bit machine doesn't seem to work with the plugins correctly.

Trying to load only 32-bit VSTs only (64-bit path blank) does not work.

Regenerating the plugin cache before or after any of the steps above did not help. The plugins in the 32-bit folder were always non-working. Try to load one from that list also fails.

Here is an entry from the scan log:

code:
EAWVstPluginsAkoustikPianoVST.dll ... new plugin added to cache ; ### ERRONEOUS ###
class psycle::host::exceptions::library_errors::loading_error
Couldn't open the library: EAWVstPluginsAkoustikPianoVST.dll


Thanks in advance for any help and support,
DaAwesomeP

31.12.2014, 03:19 Profile of DaAwesomeP Add DaAwesomeP to your Buddy-List Email to DaAwesomeP Homepage of DaAwesomeP
DaAwesomeP
Psycler



Date Registered:
12.2014
Location:

Posts: 2


DaAwesomeP ist offline
         Go on top to this Page

The forum seems to have messed up my log entry even though I put it in BB Code CODE tags. The path is supposed to be "E:>DAW>VstPlugins>AkoustikPianoVST.dll" with the ">" signs becoming slashes. This path is correct; it goes to my Native Instruments VST that is at its latest version.

31.12.2014, 03:23 Profile of DaAwesomeP Add DaAwesomeP to your Buddy-List Email to DaAwesomeP Homepage of DaAwesomeP
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1365


[JAZ] ist offline
         Go on top to this Page

Hi.

There might be several problems on your side:

First, I will quote the FAQ.txt:

quote:

Q) What is the difference between the 32bits and 64bits builds, and what implications
does it have when using VST plugins?

A) The 64bits version of Psycle is made for users of the 64bits of Windows. Both the 32 and 64bits
can be used in these OSs, but there is a restriction: The 64bits version can only load 64bit
versions of VST plugins and the 32bits can only load 32bit versions of them.
If you use a VST bit bridging, like jBridge ( http://jstuff.wordpress.com/jbridge/ ),
then that software can allow to use 32bits on 64bit version and 64bit on 32bit version.
Remember to activate the support in Psycle Directories settings.


So, by default, Psycle can only load the plugins of its same bit size. It requires a third party software to "bridge" the bits. That software is not free and is currently the only way for Psycle to support bridging.
I've seen recently that ModPlug Tracker does have native bit bridging, and I might ask them if I can port that to Psycle.

If you have jBridge, then, if the setting is enabled (as you suggest you did), when it detects a problem loading the plugin, Psycle asks to jbridge to load it.

In the build I have it seems to work.
Right now i have some 32bit plugins that crash my version of jBridge, (which is old so i cannot regenerate the cache), but other than that, it is scanning the vsts correctly.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;ĚD

01.01.2015, 20:37 Profile of [JAZ] Add [JAZ] to your Buddy-List
  « Previous Thread Next Thread »
Thread closed
Jump to:

© 2002-2007 psycledelics | Powered by Woltlab Burning Board v1 Beta4.5e ©2001 Woltlab GbR|Setup & mod for psycledelics by: SAS