PSYCLE's home     
     since may 2000
  news / home  files songs boards links all registered members about psycledelics Statistics    
Welcome to -psycledelics-. If this is your 1st visit please read the FAQ - Frequently Asked Questions You must register before you can post here: Please click above on Registration to register yourself. You do not need to register if you only want to read Threads.
Login with Username & Password:

Remember me on this PC.
-psycledelics- Discussions TECH BOARD Psycle 1.8.5RC bug/feature reports
« Previous Thread Next Thread » Show a Printable Version  Send this to a Friend  Add to Favorites
Thread closed
Author
Post [  «    1  2  3    »  ]
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1370


[JAZ] ist offline
         Go on top to this Page

Ok thanks. Eventually i'll be able to make it happen, i guess.
Most probably has to do with the introduction of the block switch feature, so i will investigate in that direction.

Also, yes, i've already made it such that the block will be unselected if you click on it. That happened when i added that the selection didn't dissapear when dragging.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

29.07.2007, 20:38 Profile of [JAZ] Add [JAZ] to your Buddy-List
psyct




Date Registered:
06.2007
Location:
Vienna
Posts: 12


psyct ist offline
         Go on top to this Page

First of all:

THANX and BIG CONGRATS to all DEVS!
This is a hot step towards the 7th tracker-heaven! (seems that among other cute things they`ve got free drinks there, as a very old wise man told me recently...).

The features I love: Lots of! For example: "replace"!

The features I dont love:
The psycle-VST-presets are not loadable. They are some kind of invisible.

If I cut notes (more than one) in an column and paste them in another column: works.
If I cut notes (more than one) in an column and paste them in the same column: doesnt work.

WinXP, SSE




Last edited by psyct on 30.07.2007, 10:11 o'clock.

29.07.2007, 22:10 Profile of psyct Add psyct to your Buddy-List
js




Date Registered:
05.2004
Location:

Posts: 143


js ist offline
         Go on top to this Page

Jaz,

My songs will not load up at all - even from version 1.8.

Thanks


__________________
Synth1 and Psycle, what more could someone ask for ?

30.07.2007, 04:23 Profile of js Add js to your Buddy-List
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1370


[JAZ] ist offline
         Go on top to this Page

psyct:

To load old psycle VST presets, you have to use the "bank manager". That will (DUH!) ...realized i forgot to activate the menu.

Paste bug: Finally! selecting the whole track and trying to paste showed the problem. thanks
Edit: suggestion: Guess you could have done this with block dragging instead of cut&paste. Anyway, now i've fixed it.


js:

I've got another person with that problem, and eventually we got around the songs loading. You should try regenerating the cache, but that might not be the only problem. (It eventually started to work again).
We've fixed a problem with the cache, in fact, and there's a possibility that it causes these problems.


On a side note:

I've been fixing some problems with the mixer machine, those knobs that don't work well (top right going to top left, and gain not going over 0.0dB's) and fixed possible problems with wire connections (checking more cases).

Also, the block switch code has been redone (the part of code that executes when the origin and destination overlap partially), and also got the problem right about dragging causing crashes.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

30.07.2007, 13:26 Profile of [JAZ] Add [JAZ] to your Buddy-List
Mattias




Date Registered:
09.2005
Location:
Belluno->Veneto->Italy->Europe->Earth
Posts: 150


Mattias ist offline
         Go on top to this Page

trying sse2... i will also open mixerdemo.psy


__________________
Site: http://gravity0.site90.com

ACIDPlanet: http://www.acidplanet.com/artist.asp?songs=753767&T=7713

31.07.2007, 14:37 Profile of Mattias Add Mattias to your Buddy-List Homepage of Mattias YIM Screenname: gravity0@jabber.org
dark_virus




Date Registered:
04.2004
Location:
Brazil
Posts: 295


dark_virus ist offline
         Go on top to this Page

Sorry to bother you, but I was thinking there's a simple (at least seems to be) mod you could do for the final release.

The 'amplitude/filter envelopes' section of 'instrument editor'. When we're editing filter/amplitude envelope parameters there's no way to go back to pattern/machine view in order to make adjustments without close the window.

Maybe this could be 'fixed' for the next release...

EDIT: also, a way of disable the preview when loading samples would be good (mainly in big wav files)


__________________
Myspace | Soundcloud

Last edited by dark_virus on 04.08.2007, 17:57 o'clock.

03.08.2007, 15:09 Profile of dark_virus Add dark_virus to your Buddy-List Homepage of dark_virus
js




Date Registered:
05.2004
Location:

Posts: 143


js ist offline
         Go on top to this Page

Machines only output to left channel and it keeps on changing reseting sound config to MME rather than ASIO


__________________
Synth1 and Psycle, what more could someone ask for ?

Last edited by js on 08.08.2007, 21:04 o'clock.

08.08.2007, 21:03 Profile of js Add js to your Buddy-List
-n0L-




Date Registered:
08.2007
Location:

Posts: 2


-n0L- ist offline
         Go on top to this Page

Hi everybody. Congratulations to developpers, great work.

I need some help, every vsti I'm loading in Psycle folder plugins are crashed or invalids. I got the latest release, and never had this problem before.

How can I solve that ?




__________________
You're selling anything you get your fucking hands on.

13.08.2007, 15:30 Profile of -n0L- Add -n0L- to your Buddy-List
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1370


[JAZ] ist offline
         Go on top to this Page

the vst's need to go to their separated folder, not in the native plugins folder.
By default the configuration uses:

psycle\plugins for natives
psycle\vst for vst plugins

you can specify the directory in the configuration dialog. Point it to your existing vst folder.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

13.08.2007, 21:29 Profile of [JAZ] Add [JAZ] to your Buddy-List
-n0L-




Date Registered:
08.2007
Location:

Posts: 2


-n0L- ist offline
         Go on top to this Page

Thanks a lot, didn't remember that since the last time I used Psycle !

Ready for fat music now, thanks again !


__________________
You're selling anything you get your fucking hands on.

14.08.2007, 00:43 Profile of -n0L- Add -n0L- to your Buddy-List
bobthefish




Date Registered:
10.2006
Location:
Canada
Posts: 79


bobthefish ist offline
         Go on top to this Page

hey,
how long till its deemed stable?
i only really wanna work with a stable release.
and,
will it have an installer file?


__________________
please come vist and add me on myspace if you like Trance music! http://www.myspace.com/bulmanchris

15.08.2007, 17:11 Profile of bobthefish Add bobthefish to your Buddy-List Homepage of bobthefish
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1370


[JAZ] ist offline
         Go on top to this Page

I plan to release it as stable by the end of this month (or in september at max).
And yes, there will be an installer aswell.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

16.08.2007, 10:19 Profile of [JAZ] Add [JAZ] to your Buddy-List
Gulars2000




Date Registered:
08.2007
Location:

Posts: 1


Gulars2000 ist offline
         Go on top to this Page

i cant seem to get anny sound from the wave in recorder.

22.08.2007, 01:19 Profile of Gulars2000 Add Gulars2000 to your Buddy-List
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1370


[JAZ] ist offline
         Go on top to this Page

wavein only works in directsound and ASIO modes for now (i'll implement wavein with MME before the final release).

If that's not the problem, then you might have to select the source origin. Use the windows mixer (or any other mixer app you have) to select the record channel. (line in,mic...)


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

22.08.2007, 18:33 Profile of [JAZ] Add [JAZ] to your Buddy-List
BJohan




Date Registered:
11.2001
Location:
travelling in france
Posts: 213


BJohan ist offline
         Go on top to this Page

quote:
Original by Dizzy
Hi!

I've occasionally used Psycle before and gave the 1.8.5RC a shot. Result:

Error Starting Program

The UNIVERSALIS.DLL file is linked to missing export KERNEL32.DLL:GetConsoleWindow.

Needless to say, I'm running Win98SE on this box. I've seen some activity in the source code repository that may be related to this, so it might already be fixed, but I thought I'd report it anyway. :)

Thanks!

Edit: FWIW I've downloaded and tested the version compiled 28-Jul-2007 with the same end result.



Today, i've completely removed the call to GetConsoleWindow, so i hope it will work on win98 :)

01.09.2007, 22:26 Profile of BJohan Add BJohan to your Buddy-List Homepage of BJohan Add BJohan to your Contact-List AIM Screenname: bohan@jabber.org (no A0L) YIM Screenname: bohan@jabber.org (no Yah00!1)
fhub




Date Registered:
07.2006
Location:
Austria
Posts: 4


fhub ist offline
         Go on top to this Page

>Today, i've completely removed the call to GetConsoleWindow, so i hope it will work on win98

Well, Im curious if that will in fact be true this time, because it had already been announced 2 or 3 times before.

But unless you also provide a non-SSE version it will not make much sense, because I doubt that someone (like me) who still uses Win98 will have such a modern CPU supporting those SSE instructions ...

Last edited by fhub on 02.09.2007, 12:30 o'clock.

02.09.2007, 11:31 Profile of fhub Add fhub to your Buddy-List
coplan




Date Registered:
01.2002
Location:
Philadelphia, USA
Posts: 27


coplan ist offline
         Go on top to this Page

I'm having problems with a few of my VSTis. Some of the patch-based ones seem to be crashing or they just don't play right when I change patch sets. Is it possible that they aren't unloading the old patches properly or entirely?

One example is with Groove Agent (the original v1), a commercial drum machine VST from Steinberg which I also discuss in this thread. I use this as an example only because it gives me a memory usage of the sample set. In most hosts where this works perfectly, I'm getting a memory usage of 20-40MB. Rarely do I see these numbers climb above that. But with Psycle, for some reason, I'll end up with 120-300MB when I change patch sets. Most of the time, all I get is a crackle like it can't completely play a patch. On some occasions, Psycle crashes (suddenly, the window disappears).

Let me know what information I can provide.

(Note: I tested this with the stable release and I have the same problems.)


__________________
Coplan

04.09.2007, 22:16 Profile of coplan Add coplan to your Buddy-List Add coplan to your Contact-List AIM Screenname: c0plan
psyct




Date Registered:
06.2007
Location:
Vienna
Posts: 12


psyct ist offline
         Go on top to this Page

quote:
Original by fhub
>Today, i've completely removed the call to GetConsoleWindow, so i hope it will work on win98

Well, Im curious if that will in fact be true this time, because it had already been announced 2 or 3 times before.

But unless you also provide a non-SSE version it will not make much sense, because I doubt that someone (like me) who still uses Win98 will have such a modern CPU supporting those SSE instructions ...



Very off topics:

Hi fhub!
Im from Vienna, and You?

06.09.2007, 21:15 Profile of psyct Add psyct to your Buddy-List
dark_virus




Date Registered:
04.2004
Location:
Brazil
Posts: 295


dark_virus ist offline
         Go on top to this Page

Whenever I close AVST Freehand, Psycle crashes and show the following message:

http://img61.imageshack.us/img61/3805/psycleerrorjq8.png

And close the section. Maybe it's a VSTi bug, but I'm putting this pic for you to check.


PS. doesn't this forum allow to put images?


__________________
Myspace | Soundcloud

08.09.2007, 06:48 Profile of dark_virus Add dark_virus to your Buddy-List Homepage of dark_virus
[JAZ]
Psycle Developer



Date Registered:
11.2001
Location:
Balaguer (Spain)
Posts: 1370


[JAZ] ist offline
         Go on top to this Page

I've experienced this bug on a few VST's. One of them is WASP VSTi.

It is a strange bug, that i can't really find out why it happens, but it is related to a feature i use to tell the plugin that a connection (wire) has been made or deleted.

The strange thing with WASP VSTi is that it only happens if I open the parameters Window and play notes (so, a conjunction of all those three events).


But you say "on close"... you mean the parameters window, or deleting the machine? Maybe i should start looking at a different place...


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

08.09.2007, 15:19 Profile of [JAZ] Add [JAZ] to your Buddy-List
[  «    1  2  3    »  ]   « Previous Thread Next Thread »
Thread closed
Jump to:

© 2002-2007 psycledelics | Powered by Woltlab Burning Board v1 Beta4.5e ©2001 Woltlab GbR|Setup & mod for psycledelics by: SAS