-psycledelics- (http://psycle.pastnotecut.org/index.php)
|- TECH BOARD (http://psycle.pastnotecut.org/board.php?boardid=2)
|-- Psycle crashes when replacing plugin (http://psycle.pastnotecut.org/threadid.php?boardid=2&threadid=3079)


From Martin12345 on 16.02.2017, 06:18:

  Psycle crashes when replacing plugin

I started to test my plugin collection and I noticed that after some time Psycle crashes when I try to REPLACE MACHINE. I relaunch Psycle and load saved project but when I try to replace plugin it crashes again and I have to start new project to bring things to normal.
Workaround:
Delete machine, add new machine - no crash.

Is it 'normal' behaviour in 1.12 ?


From Martin12345 on 16.02.2017, 06:21:

 

Another issue:
After adding (or replacing) generator, there is no sound in right channel.
I have to restart Psycle to fix it.


From [JAZ] on 16.02.2017, 21:19:

 

That feature has had a few bugs since its first appearence, IIRC in 1.10.

I thought that all of them were fixed already. I cannot be sure if the problem is on replacing the machine, or in the specific type of machine being replaced. Basically, I would not expect that replacing a native machine or effect would cause such a problem (that does not include the send-return mixer).

With VSTs and the send-return mixer, more things come into play.


The problem about not receiving audio on one channel sounds strange. The connections use internally a volume level for each channel, even if visually they are just one volume and one panning control. It might happen that the channel gets set with an incorrect value, but if you save that, It should still be silent after a restart.

Note also that Psycle connections can be modified. If you open the wire dialog (doubleclick on the arrow in the wire) and use the channel mapping, that can connect individual channels. I wonder if that was what got incorrectly setup, but again, if that gets saved, it should still be silent after a restart.

Some old versions used to close the soundcard when doing some of these changes, but nowadays the soundcard is kept open, so it cannot be a problem when reopening it.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D


From Martin12345 on 21.02.2017, 02:06:

 

Today I got right channel problem again.
If I save project before restarting the problem persists.
I checked channel mapping, right channel was 'unticked'.

Powered by: Burning Board 1.0 Beta 4.5eEnglish Translation by AnnaFan
Copyright 2001 by WoltLab