-psycledelics- (http://psycle.pastnotecut.org/index.php)
|- TECH BOARD (http://psycle.pastnotecut.org/board.php?boardid=2)
|-- Asking for Bugs (http://psycle.pastnotecut.org/threadid.php?boardid=2&threadid=1698)


From BJohan on 10.06.2005, 00:27:

 

09.23.03.48 <[angelus]> aaaah!
09.23.04.02 <[angelus]> What's that? --->
09.23.04.14 <[angelus]> and -->
09.23.04.21 <lobyaway> it is the crack edition
09.23.04.24 <lobyaway> of psycle
09.23.04.30 <[angelus]> crack?
09.23.04.31 <Miza[R]> que?
09.23.04.32 <bohan> lol
09.23.04.35 <Miza[R]> haha
09.23.04.37 <lobyaway> or the "psycledelic" version
09.23.04.42 <[angelus]> 0_o
09.23.04.44 <Miza[R]> more like it

oops.


From js on 12.06.2005, 04:59:

 

Reference: Alpha 1.7.55
Problem: No sound / distorted sound from some vst plugins when using midi keyboard with asio driver

Some vst plugins I either cannot audition them from machine view or if i can, there is distorted sound. I can only play them when I switch to pattern editor and when recording.


__________________
Synth1 and Psycle, what more could someone ask for ?


From fiasko on 12.06.2005, 14:04:

 

quote:
Original by BJohan
http://psycle.free.fr/angelus/BugScreens...achinesview.jpg



hehe, graphics design with Psycle ?



sort function used with too many patterns hangs Psycle.


From js on 12.06.2005, 21:59:

 

Reference: Alpha 1.7.55

Midi velocity needs to be reset by choosing 'cmd' when first using psycle, despite the fact that the 'Map velocity' appears to be selected.


__________________
Synth1 and Psycle, what more could someone ask for ?


From js on 12.06.2005, 22:07:

 

quote:
Original by js
Reference: Alpha 1.7.55

Midi velocity needs to be reset by choosing 'to ins' when first using psycle, despite the fact that the 'Map velocity' appears to be selected.



Btw, when selected, this seems to restore the sound back to some vst plugins and samples when in machine view.


__________________
Synth1 and Psycle, what more could someone ask for ?


From [JAZ] on 13.06.2005, 22:48:

 

quote:
Original by js
[QUOTE]Original by js
Reference: Alpha 1.7.55

Midi velocity needs to be reset by choosing 'to ins' when first using psycle, despite the fact that the 'Map velocity' appears to be selected.



Btw, when selected, this seems to restore the sound back to some vst plugins and samples when in machine view.
[/QUOTE]


If i understand you correctly, you are using a MIDI keyboard to play/enter notes, and some VST's only work if you are in the pattern editor with the record mode (record notes) enabled. Is it correct?

Also, saying that selecting the "ins" combobox for "Note Velocity" in the "MIDI Controllers" configuration page, solves the problem.

Well... If this is correct, i find it strange, because mapping the velocity to instrument makes the velocity control the MIDI channel being used.

Also, i've been checking where the midi channel is being used, and i don't see a difference between using in a screen or the other, and since I don't have a MIDI keyboard, nor know what VST's have this problem, I can't inspect further.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D


From BJohan on 17.06.2005, 01:33:

  renderering to a file

20.49.49 <@alk> http://psycle.free.fr/alk/renderer/you-know_offline.mp3
20.49.52 <@alk> http://psycle.free.fr/alk/renderer/you-know_realtime.mp3
20.50.13 <@sampler> what's that alk?
20.50.25 <@alk> for you to compare the offline and realtime recording
20.50.31 <@alk> (of the same psy)


[Edit by JosepMa (for completeness)]
http://psycle.free.fr/alk/you-know.psy


From alk on 19.06.2005, 12:44:

 

dupe it! doesn't load it's params properly (crashes psycle if you leave the params as they are, it's necessary to remove the dupe it! and re-add it to continue each time)

also, only one instance of dupe it! works (can't have two of them)

:B


From alk on 19.06.2005, 22:40:

 

great, those bugs fixed Josep, one little (not critical) one left,

when changing the param dial in dupe it jumps to -1


From fiasko on 20.06.2005, 00:10:

 

awesome free comb filter plugin: http://dsp.trilete.net/programs/Macomate_v1p0.zip

Psycle doesn't save the settings correctly

Maybe I should email the author ?


edit: weird, after loading song one has to edit one of pitch parameters to activate the plug.. saving in the preset dialog doesn't seem to work..


From Erodix on 21.06.2005, 14:27:

 

[14:21:02] Erodix now testing 1.7.56
[14:49:18] <Erodix> hm? i pressed the clear button, answered yes, and now it looks psycle went booboo
[14:50:28] <Erodix> :((
[14:50:50] Byte_ is now known as Byte
[14:51:23] <Sartorius> the same
[15:08:37] <Sartorius> hah
[15:08:50] <Sartorius> i found a bug in stk plucked
[15:17:44] <alk> -)
[15:17:49] <alk> Erodix; post it here


From DMNXS on 22.06.2005, 15:14:

 

quote:
Original by Erodix
[14:21:02] Erodix now testing 1.7.56
[14:49:18] <Erodix> hm? i pressed the clear button, answered yes, and now it looks psycle went booboo
[14:50:28] <Erodix> (
[...]


I was going to post that error at the SourceForge site. It also happened with 'sort'. I'Ve noticed it since 1.7.54.


From [JAZ] on 22.06.2005, 21:32:

 

It is a confirmed bug, and fixed already.

It appeared when i changed "MAX_PATTERNS" from 255 to 256, because there was a counter in the undo/redo code that could only grow up to 255 so it never finished.



__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D


From alk on 28.06.2005, 13:18:

  Please Help Against Bug Starvation

feed the devers, invent new bugs

http://sourceforge.net/tracker/?group_id=10834&atid=110834

(enter them here)


From fiasko on 03.07.2005, 08:37:

 

adding Blitz to exsisting song (just import xm and try to add Blitz) will crash the plugin. Starting from a clean slate Blitz seems to work fine.


From BJohan on 04.07.2005, 09:15:

 

quote:
Original by fiasko
adding Blitz to exsisting song (just import xm and try to add Blitz) will crash the plugin. Starting from a clean slate Blitz seems to work fine.



Oh, btw, the blitz plugin that comes with the alpha (or now RC) builds of psycle isn't the latest version of blitz. The reason is simply that voskomo doesn't (yet) put his source in the source code repository that is used for the builds.
You'll have to ask voskomo for the latest version (I think you can't get the latest blitz version anymore at http://voskomo.com)
As soon as vos thinks his plugin is stable, we'll upgrade the cvs.


From js on 05.07.2005, 13:37:

  Standard VST method for opening a browse window ?

Hi,

This is is'nt so much a bug as a suggestion.

Just downloaded the PAAX sampler vst, but could not load/save a sample using the default browse icons.

I sent an email to the developer, thinking that this might have been a design flaw of the instrument itself. He wrote back saying that it is a problem with Psycle. This host doesn't seem to implement a standard VST method for opening a browse window.

I'm not expecting this to be fixed soon but just thought I might pass it on so you guys are aware of the issue.

Thankyou
js


__________________
Synth1 and Psycle, what more could someone ask for ?


From [JAZ] on 05.07.2005, 20:59:

 

yes. we are aware of it. it is a VST 2.1 feature, expanded in 2.3.

In theory, the host has to supply an open dialog to the vst plugin.

This will be solved after we swap the vst host code.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D


From fiasko on 10.07.2005, 03:41:

 

not sure if this can be considered as a bug.. toxic doesn't fully save presets (oscillators are omitted)

http://www.maxxclaster.com/toxic.html


From [JAZ] on 10.07.2005, 12:04:

 

Mmm.. yes.. it probably is a bug in Psycle. The presets are saved in raw mode, (parameter by parameter), instead of using the better chunk mode that this VST allows.

Another thing to work out when switching the Host.


__________________
<[JAZ]> Pa pi pa pa pa pi pa.... ;D

Powered by: Burning Board 1.0 Beta 4.5eEnglish Translation by AnnaFan
Copyright 2001 by WoltLab